Author Topic: Alt-tuner in bitwig  (Read 180 times)

Wanja

  • Member
  • *
  • Posts: 2
    • View Profile
Alt-tuner in bitwig
« on: August 03, 2017, 04:17:04 AM »
Works alright overall, but can't get the keyswitcher to work, prob due to routing, not sure how to fix this atm so here to ask for some help if anyone has any?
I get this error on boot every time, which I assume is not a big deal unless I want to map cc and or other things using keyswitcher

Tall Kite

  • The Tall One
  • Administrator
  • Expert Member
  • *****
  • Posts: 149
    • View Profile
    • my website:
Re: Alt-tuner in bitwig
« Reply #1 on: August 03, 2017, 11:05:30 AM »
Make sure alt-keyswitcher is right before alt-tuner in the effects chain.

I don't know bitwig, but I'll take a look at it. What OS are you running?
OS: OSX 10.5.4, OS X 10.9.5, Windows 7
DAWs: Reaper, ProTools 7.4 (PT is mac only)
HARDWARE: Yamaha s90 ES, M-Audio Keystation 49e, Line 6 FBV mark II express (footpedal unit)
SOFTSYNTHS: Kontakt 4, SampleTank 3 free, Pianoteq demo, ReaSynth, all Xen-Arts synths

Wanja

  • Member
  • *
  • Posts: 2
    • View Profile
Re: Alt-tuner in bitwig
« Reply #2 on: August 06, 2017, 08:54:34 AM »
Windows machine
I think it might react similar to ableton and filters the midi

And oh my, so much to learn about this piece of software you made for us  :)

Tall Kite

  • The Tall One
  • Administrator
  • Expert Member
  • *****
  • Posts: 149
    • View Profile
    • my website:
Re: Alt-tuner in bitwig
« Reply #3 on: August 13, 2017, 11:01:32 PM »
Haven't forgotten about this, still working on learning bitwig...
OS: OSX 10.5.4, OS X 10.9.5, Windows 7
DAWs: Reaper, ProTools 7.4 (PT is mac only)
HARDWARE: Yamaha s90 ES, M-Audio Keystation 49e, Line 6 FBV mark II express (footpedal unit)
SOFTSYNTHS: Kontakt 4, SampleTank 3 free, Pianoteq demo, ReaSynth, all Xen-Arts synths

Tall Kite

  • The Tall One
  • Administrator
  • Expert Member
  • *****
  • Posts: 149
    • View Profile
    • my website:
Re: Alt-tuner in bitwig
« Reply #4 on: August 19, 2017, 05:38:39 PM »
Unfortunately, bitwig does indeed have the same problems as Ableton Live. It garbles microtonal midi. It sends all of alt-tuner's output to midi channel 1. It also filters out sysex messages. Alt-tuner simply won't work inside bitwig, except for mono tracks, and for keyswitch mode, which only works with kontakt.

So, assuming you are heavily invested in using bitwig, and don't want to switch DAWs, you need to use a virtual midi cable to connect bitwig to another DAW or VST host that runs alt-tuner. Then send the midi back into bitwig with another midi cable. Not as hard as it sounds, and you'll do most of your work in bitwig. Instructions to follow.

OS: OSX 10.5.4, OS X 10.9.5, Windows 7
DAWs: Reaper, ProTools 7.4 (PT is mac only)
HARDWARE: Yamaha s90 ES, M-Audio Keystation 49e, Line 6 FBV mark II express (footpedal unit)
SOFTSYNTHS: Kontakt 4, SampleTank 3 free, Pianoteq demo, ReaSynth, all Xen-Arts synths

Tall Kite

  • The Tall One
  • Administrator
  • Expert Member
  • *****
  • Posts: 149
    • View Profile
    • my website:
Re: Alt-tuner in bitwig
« Reply #5 on: August 19, 2017, 05:58:44 PM »
Works alright overall, but can't get the keyswitcher to work, prob due to routing, not sure how to fix this atm so here to ask for some help if anyone has any?
I get this error on boot every time, which I assume is not a big deal unless I want to map cc and or other things using keyswitcher


I'm not getting this error. And yes, it's not that big a deal.
OS: OSX 10.5.4, OS X 10.9.5, Windows 7
DAWs: Reaper, ProTools 7.4 (PT is mac only)
HARDWARE: Yamaha s90 ES, M-Audio Keystation 49e, Line 6 FBV mark II express (footpedal unit)
SOFTSYNTHS: Kontakt 4, SampleTank 3 free, Pianoteq demo, ReaSynth, all Xen-Arts synths

Tall Kite

  • The Tall One
  • Administrator
  • Expert Member
  • *****
  • Posts: 149
    • View Profile
    • my website:
Re: Alt-tuner in bitwig
« Reply #6 on: August 23, 2017, 08:01:10 PM »
OK, finally figured it out. It's much more complicated than it needs to be. But once you set it up, not too much hassle.


ONE-TIME SETUP STUFF:

First, download and install loopMIDI by Tobias Erichsen, it's free.
http://www.tobias-erichsen.de/software/loopmidi.html
Run it, and set up a dozen or so ports, named loopMIDI port 1, loopMIDI port 2, etc.
(Mac users, use IAC, which is part of OS X. Use Audio Midi Setup to set up a dozen busses.)

Next, go to github.com/ThomasHelzle/Toms_Bitwig_Scripts/blob/master/TomsGeneric/TomsGenericKeyboard.control.js
[EDIT: never mind this, use the attached file, which is already edited]
right-click the "Raw" button, and save the link in
C:\Users\(your name)\My Documents\Bitwig Studio\Controller Scripts
Mac users:
(your hard drive)/Users/(your name)/Documents/Bitwig Studio/Controller Scripts
Edit it with notepad (mac users: textedit) and about 10 lines down, find "host.defineMidiPorts(1, 1);"
Change the second 1 to a 0. This tells BWS that this "controller" doesn't receive midi.
If BWS is running, quit and restart it, to make sure it can find your script.

Next, in BWS studio, go to the dashboard, and go to settings/controllers.
Click "add controller manually", and choose "TomsScripts" and "TomsGenericKeys"
Doubleclick on "TomsGenericKeys" to rename it "loopMIDI 2" (Mac: IAC bus 2)
Choose loopMIDI port 2 (Mac: IAC bus 2) from the list for the midi input.
Make a couple more controllers for port 4, port 6, etc. In general, you'll need a pair of ports for every polyphonic instrument you're retuning. Use odd-numbered ports to send midi to alt-tuner, and even ones to receive the midi output from it. That way it's easy to avoid feedback loops. (However, if you ever run out of ports, you can use each channel of port 1 to send a midi stream, and use ports 2-17 to receive 16 streams. Ports 18-34 can handle another 16 streams, and so forth. I think loopMIDI and IAC go up to 64 ports.)


PER-SONG SETUP:

Make a BWS instrument track with some polyphonic midi in it, or a midi controller connected to it. For now, keep it to triads and tetrads. Add the "HW Instrument" device to it. It's in the hardware category. In HW Instrument, select loopMIDI port 1. For the midi channel, not sure, probably choose preserve. Set "convert pitch bend" to off on this and all other tracks (not totally sure this is necessary, especially if you're using a BWS synth).

Set up 4 instrument tracks (4 because tetrads) that all receive from loopMIDI port 2. Set "convert pitch bend" to off on each one. 1st one receives from midi channel 1, 2nd from channel 2, etc. Group them into a group track. Any effects you want to apply to your sound go on the group track.

If you're using a multi-timbral synth like Kontakt, or a multi-midi-channel synth like Pianoteq or Helm, put it on the group track. Set the output for each of the 4 instrument tracks to your synth. Set the channel output in the gray box to 1 for the 1st track, 2 for the 2nd, etc. (See last link down below)

Otherwise, put an identical instance of your synth on each of the 4 instrument tracks.

Individually ctrl-click on each track so that they're all active. (Is this necessary? Is there an easier way to do this?) Make sure monitoring is on for all 6 tracks.

To add another instrument, add another 6 tracks, using ports 3 & 4. To go beyond tetrads, set up more than 4 grouped tracks.


ALT-TUNER SETUP:

Now BWS is all set up to send single-channel midi out port 1 and receive multi-channel midi on port 2. The next step is to run alt-tuner inside some other software, since BWS can't run it. On a mac, you have to use Reaper. On Windows, you can use any DAW you like except Ableton Live, which has the same problem as BWS. You can use VSThost, which is free, see the alt-tuner manual. You'll be running alt-tuner inside ReaJS, unless you use Reaper. For this example I'll use Reaper.

In Reaper, you may need to set the audio engine to Dummy Audio, so that BWS can have ASIO4ALL all to itself (on a mac: set to "none"). It seems to be a problem on a mac if Reaper is started up before BWS.

Set up one track. Set the input to loopMIDI port 1 (Mac: IAC bus 1), all channels. Set the midi hardware output to port 2, original channels. Click the record-arm button and the monitor button. Put alt-keyswitcher and alt-tuner in the FX chain. Set alt-tuner to octave mode, 4 midi channels output (because tetrads). Set alt-tuner to whatever scale you want.

For a 2nd instrument, add a 2nd track to Reaper, using ports 3 & 4, with a 2nd instance of alt-tuner.


NOTES:

On page 353 of the BWS manual, there's a MIDI Channel Filter which looks better than Tom's scripts. But it's not actually in the program.

A good tool to use is ReaControlMIDI, which is built into Reaper, and also part of ReaPlugs, alongside of ReaJS. (Windows only) It lets you examine the midi stream. To make it work in BWS, you have to click the mostly hidden "Show Log" button on the right, near the top, next to "All Notes Off". You can also see midi activity in loopMIDI's window.

BWS's micro pitch expression sounds great, but it only works with the bundled bitwig instruments. And you have to do all the retuning manually with the mouse, one note at a time.

Helpful links:
https://www.kvraudio.com/forum/viewtopic.php?f=259&t=483740&start=15
https://www.kvraudio.com/forum/viewtopic.php?p=6076443
http://blog.thomashelzle.de/2014/04/bitwig-studio-tutorial-3-separate-midi-channels/
http://www.kvraudio.com/forum/viewtopic.php?f=259&t=488595&sid=17fecc62454f2e632d9fb07cf49824d0
http://www.kvraudio.com/forum/viewtopic.php?f=259&t=407092
https://www.reddit.com/r/Bitwig/comments/4e33l4/heres_how_to_send_midi_to_a_specific_channel/

« Last Edit: August 25, 2017, 08:13:33 AM by Tall Kite »
OS: OSX 10.5.4, OS X 10.9.5, Windows 7
DAWs: Reaper, ProTools 7.4 (PT is mac only)
HARDWARE: Yamaha s90 ES, M-Audio Keystation 49e, Line 6 FBV mark II express (footpedal unit)
SOFTSYNTHS: Kontakt 4, SampleTank 3 free, Pianoteq demo, ReaSynth, all Xen-Arts synths